Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Double Din Navigation Systems
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 11th October 2019, 08:44   #1
YorksMG2013
Gets stuck in
 
YorksMG2013's Avatar
 
MG ZT 190 SE & MG ZT 260

Join Date: Oct 2013
Location: Leeds
Posts: 684
Thanks: 81
Thanked 72 Times in 40 Posts
Default DAB and Naval Star

Hello All

My Naval Star has recently decided it doesn't want talk ro the DAB receiver. It just says 'connecting' and that seems to be it.

Any thoughts on how to remedy this please?

Cheers

Andrew
__________________
Andrew (YorksMG2013)

Proud owner of a Pearl Black facelift ZT 190 SE
(or should that be the 'Black Pearl'? Just call me Cap'n Jack!)
Now joined by the Blue Beast - MG ZT 260 #57 in Trophy Blue
YorksMG2013 is offline   Reply With Quote
Old 11th October 2019, 13:02   #2
trebor
My other car is a Jaguar XK
 
trebor's Avatar
 
Rover 75 CDTi Connoisseur SE & MG ZT Saloon 190

Join Date: Jun 2007
Location: Walsall
Posts: 11,991
Thanks: 398
Thanked 1,289 Times in 672 Posts
Default

Try the reset button which works on mine, although I don't have dab the unit is the worst I have had and has developed so many faults its best placed in the bin, I have to hit the reset button every time I get in the car and keep my fingers crossed
__________________
Click on business card below for Midlands Nano Meets Website




Robs Car Gallery

Last edited by trebor; 11th October 2019 at 13:04..
trebor is offline   Reply With Quote
Old 15th October 2019, 19:37   #3
Darcydog
This is my second home
 
MG ZT-T

Join Date: Jul 2014
Location: Fordingbridge
Posts: 7,403
Thanks: 2,575
Thanked 2,422 Times in 1,635 Posts
Default

Quote:
Originally Posted by trebor View Post
Try the reset button which works on mine, although I don't have dab the unit is the worst I have had and has developed so many faults its best placed in the bin, I have to hit the reset button every time I get in the car and keep my fingers crossed
Yes - I too am distinctly unimpressed with my Naval Star - radio reception is poor, and it’s now about 50/50 if it can pick up a satellite signal.

And yet my 10 year old Tom Tom still works fine and Google Maps on my iPhone is 100% reliable.

It’s sad because the DD unit looked so good and had so much promise which evaporated with use.

My experience with the Naval Star has put me off DD units.

Far better from my experience to stick with a basic single Din unit and a holder for an iPhone or equivalent. Save yourself a lot of money and avoid a lot of disappointment.
__________________
Ranthoneous to a T
Darcydog is offline   Reply With Quote
Old 21st October 2019, 12:00   #4
YorksMG2013
Gets stuck in
 
YorksMG2013's Avatar
 
MG ZT 190 SE & MG ZT 260

Join Date: Oct 2013
Location: Leeds
Posts: 684
Thanks: 81
Thanked 72 Times in 40 Posts
Default Star unit and DAB

Tried the reset button but no change on accessing the DAB tuner.
Disappointing as this is why I purchased a Star.
Maybe next year I can save up for an AndroidICE unit -will have to see

Andrew
__________________
Andrew (YorksMG2013)

Proud owner of a Pearl Black facelift ZT 190 SE
(or should that be the 'Black Pearl'? Just call me Cap'n Jack!)
Now joined by the Blue Beast - MG ZT 260 #57 in Trophy Blue
YorksMG2013 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:50.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd