Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 7th December 2019, 19:06   #21
bl52krz
This is my second home
 
bl52krz's Avatar
 
Rover 75 cdt club + Rover 2.5 KV6 Conni SE

Join Date: May 2008
Location: Birmingham
Posts: 9,525
Thanks: 4,834
Thanked 1,718 Times in 1,335 Posts
Default

How would shorting the battery on its own make any difference to anything apart from the battery?? Have I missed something somewhere?
__________________
Great Barr, Birmingham.
bl52krz is offline   Reply With Quote
Old 7th December 2019, 19:11   #22
dattrike
Posted a thing or two
 
dattrike's Avatar
 
V6 2ltr auto in copperleaf +CDTI Auto in Royal Blue on loan to Son

Join Date: Jul 2010
Location: Tewkesbury, Gloucestershire
Posts: 1,534
Thanks: 88
Thanked 383 Times in 215 Posts
Default

Quote:
Originally Posted by bl52krz View Post
How would shorting the battery on its own make any difference to anything apart from the battery?? Have I missed something somewhere?
Not shorting the battery, disconnect the leads and short them together
has the effect of discharging the car electrical systems, when power is reapplied the systems re boot from scratch.
__________________
dattrike is offline   Reply With Quote
Old 8th December 2019, 16:40   #23
oswestryalex
Loves to post
 
Rover 75 1.8T connoisseur saloon 2003 in blue , MG ZT 190+ 2003

Join Date: Jul 2012
Location: Oswestry
Posts: 303
Thanks: 157
Thanked 98 Times in 57 Posts
Default

Try the Norwegian 'fix' that was suggested on a similar thread. You disconnect the battery and then short the two cables across each other (not the battery of course) - reconnect and then sync the keys. I had exactly this issue and followed this procedure and it worked a treat. Seems as though there are capacitors in the circuit that need to discharge, and by shorting it out, completing the circuit, you achieve that. Give it a try - as the alternative may be to find someone with T4 to reset everything.
oswestryalex is offline   Reply With Quote
Old 9th December 2019, 15:00   #24
mikpa
Newbie
 
Rover 75 Saloon

Join Date: Mar 2016
Location: Linkoping
Posts: 6
Thanks: 0
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by vitesse View Post
I'm guessing we're talking about the remote operation ...

A member here in Sweden had the same problem a few days ago. Tried the sync procedure as per handbook, didn't help. Then tried what he referred to as a "Norwegian re-set": took one of the cables off the main battery and held it briefly against the other. Tried the sync procedure and it worked. First time I've ever heard of it.

Otherwise people tend to recommend a main battery disconnect for half-an-hour, if that fails then Toaf can reactivate remote boards.

Regards
Hi,
I am the guy that vitesse is talking about and I can confirm that the reset (by disconnecting one of the battery cables and put them together) worked for me on the 75, after I have had a serious battery discharge.
I got the idé from a garage when when I had similar discharge problems with my other car (Jaguar XK). Unfortunately it didn't cure the Jag problems. But I had to drive it to the garage and have the diagnosis computer connected. they told me that the car computers were full of failure codes.

Curiosa, why we call it "norwgian reset". We like to make fun of our neighbors in Norway ( I'm sure they do the same to us). When you have an issue with your electric (comuterized) equipment you just switch it off and on again, and the it works, Right?
We say, when norwgians have trouble whith their car, they switch it off, lock the doors, then unlock and restart it!
Disconnecting the cables and shorten them is just one step further. And it actually works - At least on Rovers...


By the way, I have now bought two of this for my cars: http://www.gunson.co.uk/content/imag...119_PIS_V2.pdf
Hopefully I will now have a chance to charge the battery before the discharge goes to far.

Last edited by mikpa; 9th December 2019 at 16:10..
mikpa is offline   Reply With Quote
The Following 2 Users Say Thank You to mikpa For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:52.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd