Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > Technical Help Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 19th November 2019, 18:02   #1
elnoxx
Newbie
 
elnoxx's Avatar
 
Rover 75 Saloon

Join Date: Aug 2019
Location: Stuttgart
Posts: 17
Thanks: 2
Thanked 1 Time in 1 Post
Question Rover 75 Key Fob Stopped Working

Hi guys,

So after driving my lovely Rover 75 for some months with zero issues i had to discover my key not working earlier today.

I first thought its a battery problem so i drove home just fine changed the battery and nothing.

I pressed the keys multiple times, helt the keys down, started the car and tried the same, opened and closed all doors just to make sure they are closed correctly.

But sadly nothing helped.


Does this seem to you guys like a broken key or maybe a sync issue?

I tried looking up ways to sync but nothing seems to work.


All doors open / close just fine using the lock.

I also took the new battery out for some time and put it back in to make sure it fits correctly.
The chance its a dead battery is quite small tbh and the old battery showed no signs of being empty prior to today.




Any tips or links to a quality replacement dealer are appreciated
elnoxx is offline   Reply With Quote
Old 19th November 2019, 18:10   #2
COLVERT
Foreign correspondent.
 
COLVERT's Avatar
 
R75 Saloon.

Join Date: Feb 2009
Location: France/or Devon.
Posts: 11,529
Thanks: 2,950
Thanked 1,418 Times in 1,228 Posts
Default

The micro chip in the key is very small and can easily fall out while changing the battery.---
__________________
COLVERT is offline   Reply With Quote
Old 19th November 2019, 18:15   #3
elnoxx
Newbie
 
elnoxx's Avatar
 
Rover 75 Saloon

Join Date: Aug 2019
Location: Stuttgart
Posts: 17
Thanks: 2
Thanked 1 Time in 1 Post
Default

Also the red lights on the key work
elnoxx is offline   Reply With Quote
Old 19th November 2019, 18:17   #4
vitesse
Posted a thing or two
 
Rover 75 Saloon Auto Conn

Join Date: Jul 2011
Location: Gävle, Sweden
Posts: 1,407
Thanks: 209
Thanked 428 Times in 347 Posts
Default

I'm guessing we're talking about the remote operation ...

A member here in Sweden had the same problem a few days ago. Tried the sync procedure as per handbook, didn't help. Then tried what he referred to as a "Norwegian re-set": took one of the cables off the main battery and held it briefly against the other. Tried the sync procedure and it worked. First time I've ever heard of it.

Otherwise people tend to recommend a main battery disconnect for half-an-hour, if that fails then Toaf can reactivate remote boards.

Regards
vitesse is offline   Reply With Quote
The Following 2 Users Say Thank You to vitesse For This Useful Post:
Old 19th November 2019, 18:36   #5
elnoxx
Newbie
 
elnoxx's Avatar
 
Rover 75 Saloon

Join Date: Aug 2019
Location: Stuttgart
Posts: 17
Thanks: 2
Thanked 1 Time in 1 Post
Default

Yes i was talking about the remote function key it self works fine.

Are you talking about the cars battery or the keys?

Thanks.
elnoxx is offline   Reply With Quote
Old 19th November 2019, 18:57   #6
vitesse
Posted a thing or two
 
Rover 75 Saloon Auto Conn

Join Date: Jul 2011
Location: Gävle, Sweden
Posts: 1,407
Thanks: 209
Thanked 428 Times in 347 Posts
Default

Quote:
Originally Posted by elnoxx View Post
Yes i was talking about the remote function key it self works fine.

Are you talking about the cars battery or the keys?

Thanks.
The car's main battery. His method, I've never hear of it before, use at your own discretion.

Regards
vitesse is offline   Reply With Quote
Old 20th November 2019, 08:16   #7
aussiejames
Newbie
 
Rover 75 Saloon

Join Date: Nov 2019
Location: Perth
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

Sounds like we are having the exact same problem ( and we do not have a spare remote..) I will disconnect the car's battery tonight and see if the 'turn it off and back on ' fix works EDIT: disconnected car battery -ve for 30 mins, sync key ( pressed lock 4 times quickly ). Remote still does not work. Holding down either lock or unlock button the light flashes- this is normal?

Last edited by aussiejames; 20th November 2019 at 10:36.. Reason: update
aussiejames is offline   Reply With Quote
Old 20th November 2019, 17:25   #8
Vifor
Newbie
 
Rover 75 saloon

Join Date: Nov 2019
Location: Arucas
Posts: 22
Thanks: 11
Thanked 4 Times in 2 Posts
Default

First I would open the case and make sure that the open and close switches are still in place. In one of my keys the open one was loose. Had it soldered and working fine now.

Regards
Vifor is offline   Reply With Quote
The Following User Says Thank You to Vifor For This Useful Post:
Old 20th November 2019, 21:25   #9
patrolman pete
Posted a thing or two
 
Rover 75 club se tourer CDT and a Connoisseur SE Diesel Auto Saloon

Join Date: Nov 2006
Location: Houghton - le - Spring
Posts: 1,118
Thanks: 492
Thanked 170 Times in 122 Posts
Default

This might sound daft but have you tried driving to another location and trying the key again ? This happened to me a few years ago when my remote function stopped working at home but when I later went to the shops it was fine. I came home and it stopped again ! This went on for a couple of days before righting itself. My only thought was signal interference from some source such as phone mast or remote doorbell close to my drive ?

Anyway it never happened ever again !
patrolman pete is offline   Reply With Quote
The Following User Says Thank You to patrolman pete For This Useful Post:
Old 21st November 2019, 07:22   #10
elnoxx
Newbie
 
elnoxx's Avatar
 
Rover 75 Saloon

Join Date: Aug 2019
Location: Stuttgart
Posts: 17
Thanks: 2
Thanked 1 Time in 1 Post
Question

Thank you guys for the answers but sadly nothing helped so far.

My GF had a spare key which she tried yesterday but it also didnt work (her key is way newer and worked before) which makes me think its one of these 3 things:

1. The car forgot its own unlock key / reset the key to something else.

2. The chip is stuck here a fuse pull or battery removal might help (will try that this weekend).

3. The chip inside of the car broke its "wireless" function which just means its not going to work anymore.


I will try pulling the fuse on friday when i have a little bit of time, i will also have to create a new post for that as i have no idea what fuse to pull lol.
elnoxx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:56.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd