Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > I.C.E. Forum > Sat Nav Hardware & Software > Factory Fit Highline & Lowline Navigation Systems
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 10th March 2014, 19:35   #1
johnnybbad
Loves to post
 
johnnybbad's Avatar
 
mgzt

Join Date: Sep 2013
Location: Connahs Quay
Posts: 356
Thanks: 85
Thanked 100 Times in 72 Posts
Default Hi-line problems

Hi all

Bought a zt off a fellow member from here, came bundled with a hi-line unit but have been told that the radio receiver has had a dunking and is no good ( took it out and main power area on unit is pretty much melted )

The unit automatically powers on when you switch on ignition, and you cannot switch it off on rotary control

Satnav and tv menus come up on screen, but no radio / cd menus, and no sound can be heard

Is this due to the radio receiver being fried ? do all the main cd / radio functions go through this unit ?

Someone is selling one on here so just trying to make sure it will solve the problem before purchasing

Thanks John
johnnybbad is offline   Reply With Quote
Old 10th March 2014, 19:41   #2
STUBIE
This is my second home
 
STUBIE's Avatar
 
Back in a Rover

Join Date: Nov 2006
Location: Peterborough
Posts: 4,825
Thanks: 112
Thanked 321 Times in 235 Posts
Default

Yes the radio unit the the amp sort of where the sound comes from, so yes I would say the unit is a goner.

Stubs
STUBIE is offline   Reply With Quote
Old 9th April 2014, 22:44   #3
bigbird
Gets stuck in
 
Rover 75 V.V.C.. Connoisseur

Join Date: Jan 2012
Location: Dalton in Furness Cumbria
Posts: 557
Thanks: 24
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by johnnybbad View Post
Hi all

Bought a zt off a fellow member from here, came bundled with a hi-line unit but have been told that the radio receiver has had a dunking and is no good ( took it out and main power area on unit is pretty much melted )

The unit automatically powers on when you switch on ignition, and you cannot switch it off on rotary control

Satnav and tv menus come up on screen, but no radio / cd menus, and no sound can be heard

Is this due to the radio receiver being fried ? do all the main cd / radio functions go through this unit ?

Someone is selling one on here so just trying to make sure it will solve the problem before purchasing

Thanks John
Please tell me this isnt the unit i just bought off you
bigbird is offline   Reply With Quote
Old 10th April 2014, 00:07   #4
johnnybbad
Loves to post
 
johnnybbad's Avatar
 
mgzt

Join Date: Sep 2013
Location: Connahs Quay
Posts: 356
Thanks: 85
Thanked 100 Times in 72 Posts
Default

Quote:
Originally Posted by bigbird View Post
Please tell me this isnt the unit i just bought off you
I bought a replacement radio unit off stubie as that was the problem

The complete set up I have just sold to you is fully working
johnnybbad is offline   Reply With Quote
The Following User Says Thank You to johnnybbad For This Useful Post:
Old 10th April 2014, 21:12   #5
bigbird
Gets stuck in
 
Rover 75 V.V.C.. Connoisseur

Join Date: Jan 2012
Location: Dalton in Furness Cumbria
Posts: 557
Thanks: 24
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by johnnybbad View Post
I bought a replacement radio unit off stubie as that was the problem

The complete set up I have just sold to you is fully working
Can i just say what a true gent this fella is not only did i buy a fully working system but he also phoned me and gave me fitting instructions
bigbird is offline   Reply With Quote
The Following User Says Thank You to bigbird For This Useful Post:
Old 11th April 2014, 17:23   #6
johnnybbad
Loves to post
 
johnnybbad's Avatar
 
mgzt

Join Date: Sep 2013
Location: Connahs Quay
Posts: 356
Thanks: 85
Thanked 100 Times in 72 Posts
Default

Quote:
Originally Posted by bigbird View Post
Can i just say what a true gent this fella is not only did i buy a fully working system but he also phoned me and gave me fitting instructions
Glad to help out Graham
johnnybbad is offline   Reply With Quote
Old 2nd May 2014, 16:16   #7
Rob65
Regular poster
 
Rob65's Avatar
 
75 connoisseur se

Join Date: Apr 2014
Location: Ashford
Posts: 65
Thanks: 31
Thanked 15 Times in 13 Posts
Default

Hi all
New to the club & new to 75's !
Same sort of problem with my high line too!

The unit automatically powers on when you switch on ignition, and you cannot switch it off on rotary control

Satnav and tv menus come up on screen, but no radio / cd menus, and no sound can be heard.
The cd auto changer in glove box has power, and whirs when the cd cassette is inserted, but no sound at all from speakers.
Reading these threads, I'm guessing the radio unit in the boot is kaput?
Where can I get a replacement at decent money? If I fit a new boot unit, will the radio/cd work ok ? ( I'm bored of singing to myself!)

Any advice/assistance greatly received

Regards
Rob
Rob65 is offline   Reply With Quote
Old 2nd May 2014, 16:18   #8
Simondi
Moderator
 
Simondi's Avatar
 
ZT 190 SE, MGTF, MG ZS Exclusive

Join Date: Sep 2007
Location: Kilwinning
Posts: 12,799
Thanks: 1,080
Thanked 2,570 Times in 1,380 Posts
Default

You have a pm
Simondi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:55.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2006-2020, The Rover 75 & MG ZT Owners Club Ltd