Go Back   The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club Forums > The 75 and ZT Owners Club General Forum
Register FAQ Image Gallery Members List Calendar Search Today's Posts Mark Forums Read
Notices

Reply
 
Thread Tools Display Modes
Old 19th February 2019, 12:10   #11
KevF6
Loves to post
 
KevF6's Avatar
 
Rover 75

Join Date: Jul 2016
Location: Luton
Posts: 351
Thanks: 37
Thanked 87 Times in 69 Posts
Default Help - throttle response

Ok so Trikey (Andy) very kindly checked my T4 a couple of weeks ago and there is no error history - ever, so no error messages. He also suggested that it can’t be the fuel filter as it would cut out. So now I’m at a loss, I still have intermittent juddering when using the throttle.

Has a one got any ideas?

Appreciate the help!

Kev
__________________


Done:
New leather & walnut steering wheel, headlight restore, new badges to rear & engine, walnut facia trims, full size spare wheel, timing belts, Plenum spy hole, DD head unit.



• This vehicle was the 67,855th 75 to run off the production line, out of 112,381
• This vehicle was the 2,457th 75 2.5 V6 Connoisseur SE to be made out of 3,671
KevF6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:07.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2006-2019, The Rover 75 & MG ZT Owners Club Ltd